Fix: Your Device Isn't Compatible with This Version Error on Diablo Immortal

Fix: Your Device Isn’t Compatible with This Version Error on Diablo Immortal

After a long wait, Blizzard’s latest game Diablo Immortal was released recently with great fanfare. But nowadays, when some players try to download Diablo Immortal on their device, they get an error message saying, “Your Device Isn’t Compatible with This Version,” and they are worried about how to handle the same problem. 

There can be several reasons for the same issue, such as mounted cache files, outdated software and many more. However, if you are also suffering from the same error message, then you are at the right place. Here in this article, we have listed a few solutions to overcome the same issue quickly and permanently. Then let’s have a look. 

Fix 1: Check the Minimum requirement of the Game

Before moving on to any solution, you need to make sure that your device meets the minimum requirements for running the game. Then, you can go to Blizzard’s official website, select your operating system, see the minimum requirements stated there, and make the necessary changes to your device.

Fix 2: Update Play Store

Sometimes updating your Play Store might help you to resolve the “Your Device Isn’t Compatible with This Version” Error on Diablo Immortal. To do so, 

  • Firstly, open the Play Store and click on the Profile icon.
  • Then select Settings and choose the About option.
  • And click on the Update Play Store under the Play Store Version section. 
  • Once updated, try again to install the game on your device. 

Fix 3: Update Software

In most cases, simply updating the device software will allow you to escape from the “Your Device Isn’t Compatible with This Version” error on Diablo Immortal. To do so, 

  • Firstly, open the Settings and click on the About phone option from the bottom of the screen.
  • On the new screen, tap on the Software update link and click on the Download and install option. 
  • Once done, try again to install the game on your device. 

Fix 4: Clear Play Store Cache

If you received the “Your Device Isn’t Compatible with This Version” error on Diablo Immortal, then it might be due to mounted cache files. In this case, you need to clear the cache as soon as possible to resolve the same error. To do so, 

  • Firstly, open the Settings menu on your device and click on the Installed Apps.
  • Then select the Google Play Store and tap on the Storage option.
  • Then tap on the Clear cache and Clear data option as well. 

Fix 5: Reinstall the Game

If none of the above solutions helps you, you need to uninstall the game on your device. When done, go to Google Chrome and download the game from there. If the first version of the game gets installed from Chrome, this time, you need to download the game from the Play Store.

These are all about the “Your Device Isn’t Compatible with This Version” Error on Diablo Immortal and its fixes. If you have any queries or concerns regarding this article, you can leave a comment in the comment box below.

 

Leave a Comment

Your email address will not be published. Required fields are marked *

Scroll to Top